Announcement

Collapse
No announcement yet.

Black Magic Design Intensity Pro 4K and Desktop Video

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Black Magic Design Intensity Pro 4K and Desktop Video

    I have a Black Magic Design Intensity Pro 4K, Does Edius X 10.3 require a specific version of desktop Video (for win 10 pro) or can I just install the latest version 12.2.2?

  • #2
    I use the latest version
    System Asus WS Z390 Pro MB, CPU i9 9900K, 32gb 3000mhz Ram, EVGA GTX1070TI, BM IP4K Win 10, BD Burner 1 Evo 840 and 4 Hotswap caddies
    Plugins Vistitle 2.8, TP7, NB TFX5
    Monitors Samsung 32 inch tv as main 1 LG M2350D,1 D2343 1 DM2350D as output to (3D) IP4K, PXW X70,Canon FX400

    Comment


    • #3
      same here, latest version
      Anton Strauss
      Antons Video Productions - Sydney

      EDIUS X WG with BM Mini Monitor 4k and BM Mini Recorder, Gigabyte X299 UD4 Pro, Intel Core i9 9960X 16 Core, 32 Threads @ 4.3Ghz, Corsair Water Cooling, Gigabyte RTX-2070 Super 3X 8GB Video Card, Samsung 860 Pro 512GB SSD for System, 8TB Samsung Raid0 SSD for Video, 2 Pioneer BDR-209 Blu-ray/DVD burners, Hotswap Bay for 3.5" Sata and 2.5" SSD, Phanteks Enthoo Pro XL Tower, Corsair 32GB DDR4 Ram, Win10 Pro 21H2

      Comment


      • #4
        Thx, I"ll just install the latest one then, not sure if it's important to update everytime a new desktop video version comes out?

        Comment


        • #5
          With Blackmagic I would not bother to change unless something is not working. They sometimes break things with new drivers. I am still using 11.5.1.
          EDIUS silver certified trainer.
          Main edit laptop: DVC Kaby Lake desktop processor laptop, 32GB RAM, 3.5Ghz i5 desktop processor, nVidia 1060, Windows 10.
          Desktop: 4Ghz 9900K processor, 32GB RAM, nVidia 1660TI GPU, Windows 10.
          Desktop: 2Ghz 12 core Xeon processor, 32GB RAM, nVidia 1060, BM Intensity Pro, Windows 10

          Comment


          • #6
            Yes, I have seen this being mentioned in the past, that's why I asked, 12.2.2 seems to be working fine and I"ll just stay with that version, if it aint broke... :)

            Comment

            Working...
            X