Announcement

Collapse
No announcement yet.

Disk write cache enabled or disabled

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SRsupport
    replied
    And I am sure your wife will disagree. :)

    Leave a comment:


  • GrassValley_BH
    replied
    Originally posted by antonsvideo View Post
    I was talking to a disk expert and he said that enabling write cache on video drives is meaningless since video files are usually larger than the cache, so the cache does not get used in any case
    For video it doesn't necessarily help. But it doesn't really hurt either, especially if you have battery backup.

    It can make a huge difference when there are lots of small writes to the drive. It's like doing a large shopping trip at the store one time instead of doing multiple small trips.

    Leave a comment:


  • THoff
    replied
    The interface speed is twice as fast now, but even the 1.5GB/sec SATA speed is more than sufficient to saturate the sustained transfer rate of the hard drive.

    I'm sure the system will benefit from the removal of the jumper, but I wouldn't expect a night-and-day difference.

    Leave a comment:


  • antonsvideo
    replied
    that could certainly have been a cause, your disk should be twice as fast now

    Leave a comment:


  • Stereodesign
    replied
    Thanks for the info, jumpers now removed.
    Maybe this will rid this PC of the "disk too slow" error it suffers from?

    Leave a comment:


  • antonsvideo
    replied
    the jumper was added by the factory so that the drive is seen and detected by ancient computers, basically it was added to prevent a flood of hard disks being returned because they appear to be dead, when in fact the PC is to old for SATA II

    so, yes, remove the jumper

    Leave a comment:


  • Stereodesign
    replied
    Check if there is a SATA150 pin that's enabled on the drives, usually you remove that pin and it turns into SATA 3.0Gbps
    My ASUS MoBo is 3.0gb/s capable, but the drives have the jumper in place to limit speed to 150Mb/s, does this mean I should remove the jumpers for increased disk speed?

    Leave a comment:


  • antonsvideo
    replied
    Originally posted by SoundFreak View Post
    I assume that your boot drive is also Sata II, when you installed Windows XP did you enable the "Enhanced AHCI" driver for your driver ? and did you install XP using the "F6" key and loaded the AHCI drivers to get full speed on your Sata II drives ?

    If no Bios option is set and no AHCI Drivers are loaded you are likely to get this "Disc Write Cache" issue.

    If no drivers were installed there is NO fix to load them now, you'll need to perform a format C.

    Note : Windows vista has these drivers as a standard on the disc, this is a post XP driver.
    You can easily use Nlite (freeware) to slipstream e.g. AHCI drivers, Mobo Drivers, SP3 etc. in to your XP Setup disc.
    yes to all

    disk speed is great on all drives

    C drive does 105mb/sec

    I went to the registry and checked the UserWriteCache parameter for each drive and all of them were set to value 1 (on)

    I set them all to value 0 (off) and rebooted

    now I can select the write cache option again, so greyed out with no tick may simply mean that it is on already)

    note, my drives are striped raid 0

    I was talking to a disk expert and he said that enabling write cache on video drives is meaningless since video files are usually larger than the cache, so the cache does not get used in any case

    Leave a comment:


  • SoundFreak
    replied
    Originally posted by antonsvideo View Post
    I have enabled it on all drives and then rebooted

    now when I check, all drives have the tick removed and it is greyed out on all Sata II drives, so I can no longer enable it
    I assume that your boot drive is also Sata II, when you installed Windows XP did you enable the "Enhanced AHCI" driver for your drives ? and did you install XP using the "F6" key and loaded the AHCI drivers to get full speed on your Sata II drives ?

    If no Bios option is set and no AHCI Drivers are loaded you are likely to get this "Disc Write Cache" issue.

    If no drivers were installed there is NO fix to load them now, you'll need to perform a format C.

    Note : Windows vista has these drivers as a standard on the disc, this is a post XP driver.
    You can easily use Nlite (freeware) to slipstream e.g. AHCI drivers, Mobo Drivers, SP3 etc. in to your XP Setup disc.
    Last edited by SoundFreak; 05-09-2008, 08:23 AM.

    Leave a comment:


  • antonsvideo
    replied
    I have removed the jumpers on all drives before I installed them, this is the first thing I do

    Leave a comment:


  • STORMDAVE
    replied
    Check if there is a SATA150 pin that's enabled on the drives, usually you remove that pin and it turns into SATA 3.0Gbps. Check the drive manual, maybe this is the problem.

    Leave a comment:


  • antonsvideo
    replied
    I have enabled it on all drives and then rebooted

    now when I check, all drives have the tick removed and it is greyed out on all Sata II drives, so I can no longer enable it

    something strange going on here


    however, the two Mobile Rack IDE drives are still enabled and not greyed out

    must be something to do with Sata II

    Leave a comment:


  • STORMDAVE
    replied
    If you have the drives installed, then install a fresh version of XP Pro, disk cache is enabled by default.

    Don't worry about it, enable it.

    Leave a comment:


  • antonsvideo
    replied
    after inserting all Sata II Seagate drives in my new Supermicro, the write cache was off by default, and currently is still off

    maybe a Seagate thing?

    Leave a comment:


  • STORMDAVE
    replied
    Leave it enabled. By default, XP SP2 and Vista have it enabled.

    I remember back in the day (Early 2000) there were problems with these settings and older computers, now everything is much better.

    Leave a comment:

Working...
X