No announcement yet.

AVC video decoding bug in Edius 8.1?!

  • Time
  • Show
Clear All
new posts

  • AVC video decoding bug in Edius 8.1?!


    There seems to be an AVC decoding bug in Edius 8.1 (8.10_0188). At regular intervals Edius shows the wrong frame. In real-time playback it looks like stuttering. When viewing frame-by-frame, it is easy to see that wrong frame is shown.

    I have confirmed that the problem is in Edius decoding. If I use ffmpeg first to decode the clip, it works ok in Edius. Edius 8.0 (8.00_0089) is able to decode the clip just fine! The clips play back also fine in e.g. VLC and WMP.

    I have put a short sample here:

    First part is real-time, and the second part is slowed down a lot. In the second part, the problem can clearly be seen.

    Extract from MediaInfo:
    Format : MPEG-4
    Format profile : QuickTime
    Codec ID : qt
    Overall bit rate mode : Variable
    Overall bit rate : 25.9 Mbps
    Writing library : Apple QuickTime : iPhone 6s Plus : 9.1

    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : [email protected]
    Format settings, CABAC : Yes
    Format settings, ReFrames : 1 frame
    Format settings, GOP : M=1, N=60
    Codec ID : avc1
    Codec ID/Info : Advanced Video Coding
    Bit rate : 25.8 Mbps
    Width : 1 920 pixels
    Height : 1 080 pixels
    Frame rate mode : Variable
    Frame rate : 59.940 fps
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive

    Has someone else seen this? I noticed the problem when updating Edius to 8.1 while working on a project. Suddenly, this problem appeared in clip view, timeline, and in the exported files. ;(


    Last edited by Slartibart; 12-29-2015, 03:39 PM.
    Artic Video Productions

  • #2
    Update: GV Browser 8.10_0188 decodes the files ok, but not Edius!

    I have now re-checked this by first downgrading to 8.0, and then again upgrading to 8.1. Still the same...

    Really annoying! Any ideas?
    Artic Video Productions


    • #3

      Thanks. I have been thinking about something like that, but where can I find that option to disable hardware decoding??? I have browsed through all settings, but could not find it.
      Artic Video Productions


      • #4
        Anton Strauss
        Antons Video Productions - Sydney

        EDIUS X WG with BM Mini Monitor 4k and BM Mini Recorder, Gigabyte X299 UD4 Pro, Intel Core i9 9960X 16 Core, 32 Threads @ 4.3Ghz, Corsair Water Cooling, Gigabyte RTX-2070 Super 3X 8GB Video Card, Samsung 860 Pro 512GB SSD for System, 8TB Samsung Raid0 SSD for Video, 2 Pioneer BDR-209 Blu-ray/DVD burners, Hotswap Bay for 3.5" Sata and 2.5" SSD, Phanteks Enthoo Pro XL Tower, Corsair 32GB DDR4 Ram, Win10 Pro


        • #5
          Thanks, but what version is that? I don't have that option in Edius 8.1:

          Artic Video Productions


          • #6
            It depends on your whether your Motherboard has Quick Sync ability.
            1: Intel 13900K, Asus ROG Z790 Hero, G. Skill Trident Z5 6400 64G DDR5, Asus Tuff Gaming GeForce 4070Ti, WD SN850XNVMe 1T, 4T (2), Seagate IronWolf NAS 7200 14TB, Lian Li Galahad 360, Aja Kona 4, Super Flower Leadex Platinum 1600W

            2: 3970X Threadripper, Asus ROG Strix TR40 E Gaming, G. Skill Trident Z Neo 128G DDR4 3600, EVGA GeForce RTX 2080Ti, Samsung 970 EVO M.2 1T, Intel 660P M.2 2T (2), Seagate Ironwolf NAS 12T, Enermax TR4 360 AIO, Lian Li 011 DXL, AJA Kona 4, Asus ROG Thor 1200


            • #7
              Thanks. Yes, is does (Asus Z170-A Skylake). But was it so that the onboard graphics adapter needs to be enabled to use Quick Sync?

              Anyway, as that option is not available, I assume hardware decoding is not enabled.

              Any other suggestions?
              Artic Video Productions


              • #8
                Originally posted by Slartibart
                Thanks. Yes, is does (Asus Z170-A Skylake). But was it so that the onboard graphics adapter needs to be enabled to use Quick Sync?

                Anyway, as that option is not available, I assume hardware decoding is not enabled.

                Any other suggestions?
                See here (Post-#3):

                regards kurt
                HW: ASUS Z170-A; Proz: i7-6700K; RAM: 32 GB DDR4; GPU: RTX-3070, 8GB GDDR5; SSD: SAMSUNG-850-Pro, 500 GB
                SW: WIN-10/64 PRO (22H2-19045-2364​​), Firefox u.a.
                NLE: EDIUS-X(10.34.11471)-WG​​​; RESOLVE-18.6.00006 Studio
                // Read > Test > Understand


                • #9
                  Update: I tested using the tool Mp4Cam2AVI to convert the container from Quicktime MOV to AVI (without touching the video stream). This decodes fine in Edius 8.1!

                  MediaInfo however shows one difference: CodecID changed from "avc1" to "H264". Other video parameters are the same (also "Format: AVC"), so it is not re-encoded. Writing the AVI-file from Mp4Cam2AVI is also instantaneous.

                  What is going on? Looks like the problem might be QT MOV?

                  Note: As I mention above, these files are decoded ok in Edius 8.0, and also in GV Browser 8.1?!

                  I just tried the evaluation copy of Premiere Elements 14, and no problems.
                  Artic Video Productions


                  • #10
                    Thanks, good idea! The re-wrapping did however not help. Same error still in decoding. Video parameters in MediaInfo are now also identical to the original.

                    Note that this problem is not specific for one file. I have the same problem in ALL iPhone 6 and 6s files. Both 1080p60fps, and 4K 30fps.

                    Strange if nobody else experiencing this?
                    Artic Video Productions


                    • #11
                      Question: Are there any changes in Edius 8.1 related to decoding of Quicktime MOV files? It looks like Quicktime Player is no longer needed? At least not in 8.1. Maybe the same was true for 8.0?

                      The only relevant info I could find in the Edius 8.1 Release Notes is the part about support for Skylake Quick Sync decoding/encoding. I do have the Skylake platform.

                      I tried to enable the onboard Intel graphics adapter in the BIOS. Then the "hardware decoding" option became available in Edius. It does not however matter if it is selected or not. The decoding of the MOV-file still does not work properly ;(
                      Last edited by Slartibart; 12-29-2015, 02:42 PM.
                      Artic Video Productions


                      • #12

                        I re-created the project. Now with hardware decoding enabled from start. Seems to work now! No issues in a ~5 minute quick edit.

                        So far so good! I will check this some more, but it seems (at least on my setup) that iPhone 6/6s files need Quick Sync activated!
                        Artic Video Productions