Announcement

Collapse
No announcement yet.

region with YUV curve - buffer/processor limitation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • region with YUV curve - buffer/processor limitation

    Edit with hidef all the time, works great - no realtime issues.

    However when I use a region filter with a YUV curve placed outside of the region (creating a dark edged mask), the buffer runs out almost immediately.

    This is on SD material also. So doesn't appear to be bottleneck based on HD throughput. Conclusion appears to be region is very processor intensive - but no more so with SD than HD.

    Anyone willing to give the region/YUV a try and tell me your results?

    My system is pretty fast in every other filter/transistion situation.

    thanks

  • #2
    I tried that on a Core2Duo 6600 with 2Gb DDR2 and RAID0 Array...No problems with SD footage, no problems with HDV footage...no problems with DVCPRO HD footage...
    What are your system's specs?
    Aristotelis Bafaloukos
    Systems Engineer, Video Editor, 3D Artist
    BEng (Hons), MSc, MBCS

    Ctrl+Alt+Delete

    Comment


    • #3
      Core2Duo T7200 2GB ram using DVCproHD and SD progressive footage.

      (No RAID but this appears to be a processing issue not a throughput -drive i but I could be wrong)

      It works but runs out of buffer very quickly.

      Comment


      • #4
        How big is the buffer, out of curiosity?

        Comment


        • #5
          In either case (HD/SD) I have buffer on max - can't remember what it is... don't have edius in front of me.

          But I've tried playing from pre-buffer (shift+space) and from just play. It doesn't make any difference the buffer empties within a short amount of time.

          No other effect or filter places this load on the buffer.

          If you perform the YUV curve without region - no problem.

          Comment


          • #6
            This is strange I just tried it in the following projects and it works on my notebook
            1920X1080 with true 1920 footage played (buffer dropped to 20 -stationary-but it kept playing)
            1440x1080 with true 1440 footage played (buffer climbed when playing)
            1280x1080 with 1440 footage (buffer climbed when playing)

            I have 2 gig of ram and my buffer is set to 512 mb

            btw I had my anti virus program its real time monitoring running to put more strain on the system.

            I think there is something wrong at your end
            Steve
            EDIUS Trainer, Grass Cutter Gold
            A proud EDIUS EDITOR
            For more information on the Grass Cutter program please visit: http://www.grass-cutters.net

            Comment


            • #7
              Thanks for trying it.

              But I've two systems with seperate Edius installations, I've had this glitch with different versions of edius, and fresh installations on both.

              Comment


              • #8
                2 different people have tried it for you and it plays back on our systems. I guess there is some little detail you are missing.
                The audio mixer and/or waveform monitor/ vectorscope are closed right? The buffer is set to 512 mb?
                Steve
                EDIUS Trainer, Grass Cutter Gold
                A proud EDIUS EDITOR
                For more information on the Grass Cutter program please visit: http://www.grass-cutters.net

                Comment


                • #9
                  The same effect plays OK here with my lowly P4 too.

                  There must be something else going on - maybe a clip on a network drive or something?

                  Comment


                  • #10
                    Well thanks once again for trying. My buffer is maxed out.

                    Just to re-iterate Region/YUV does work, it just drains my buffer quickly and no other filter does this - which is why its so annoying.

                    Comment


                    • #11
                      On my system the buffer climbs and does not drain in a dvcprohd project
                      Steve
                      EDIUS Trainer, Grass Cutter Gold
                      A proud EDIUS EDITOR
                      For more information on the Grass Cutter program please visit: http://www.grass-cutters.net

                      Comment


                      • #12
                        Try reducing your buffer to the minimum and see if that makes a difference.

                        Comment


                        • #13
                          I wonder if he has the audio mixer open? that would do it
                          Anton Strauss
                          Antons Video Productions - Sydney

                          EDIUS X WG with BM Mini Monitor 4k and BM Mini Recorder, Gigabyte X299 UD4 Pro, Intel Core i9 9960X 16 Core, 32 Threads @ 4.3Ghz, Corsair Water Cooling, Gigabyte RTX-2070 Super 3X 8GB Video Card, Samsung 860 Pro 512GB SSD for System, 8TB Samsung Raid0 SSD for Video, 2 Pioneer BDR-209 Blu-ray/DVD burners, Hotswap Bay for 3.5" Sata and 2.5" SSD, Phanteks Enthoo Pro XL Tower, Corsair 32GB DDR4 Ram, Win10 Pro 21H2

                          Comment


                          • #14
                            anton - I know about the realtime audio mixer/buffer thingy, and it's not open.

                            I'm just talking about a specific incident with this one filter, everything else is 100% spot on.

                            BH - will try reducing buffer.

                            I'm going to try and get a video up of it today.

                            Comment


                            • #15
                              Bit of a breakthrough in nailing the problem. (but not solving it)

                              The problem only occurs with "soft-edge" set to on.

                              So it needs to be region+YUV+soft-edge then buffer reduces quickly.

                              However I need soft-edge turned on for a gradual drop to darkness around the region edge.

                              Comment

                              Working...
                              X