Announcement

Collapse
No announcement yet.

Interlaced artefacts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Interlaced artefacts

    On DVXUser Forum suggested to ask it here, since the question is related to Edius.

    I have a DSLR camera which makes 1920x1080p25 .MTS clips by using 50i wrapper. So, to be precise, it makes progressive footage, but it is "packed" by interlaced wrapper.

    First I defined a project as 1920p25. Then I imported 50i MTS clip into bin window and marked it as progressive (right click - properties). After that I placed it into the timeline and export it by using Canopus HQ Fine or Canopus Lossless codec.

    The results are here (note that the pictures are cropped and 2x magnified):

    Edius Canopus HQ Fine:


    Edius Canopus Lossless:


    You can clearly see some artefacts on both clips even though Lossless is slightly better. On the other side, when importing the same original MTS clip into VirtualDub (by the help of AviSynth), and exporting the clip by using the same two codecs, I get the following result:


    VD Canopus HQ Fine:


    VD Canopus Lossless:


    There is a clear difference. How do you edit with Edius (with 50i footage) in order to get rid of the mentioned artefacts?? Why selecting a clip property to be progressive apparently does not work?

    Importing Canopus file created by VirtualDub into Edius does not solve the problem, since it is still marked as interlaced.

    Problem exists either in Edius 6.02 or in Edius Neo.

  • #2
    At first, a clip processed by Virtualdub results always in a frame based progressive clip without any flag to recognize the right field dominance!
    From my experience I think that if EDIUS does not find a field order flag it will be always switched to TopFieldFirst for default!
    You always need to set the right field order manually in other NLE's!

    I have to say comparing your provided images is not fair from my view as long as some color shrinks are in every single image & as long as you save it in a lossy image format!

    Needs a closer look an that!

    Next time you would like to share images please do this better in a PSD or TIFF with layers and use the full frame screen shot without any resizing! Thank you!

    In general I don't know how EDIUS does the frame processing but since no effect is laid over the video track just the RAW video should be processed in the same condition as it has been decoded!

    Do a test:
    Mount the already created & used AVISynth script by the AVFS (AVISynth file system) as an virtual uncompressed AVI & load this in EDIUS.
    Do a new comparison!

    Cheers
    Andreas Gumm
    post production / authoring
    PC 1Intel Core i7-970 (6 x 3.20 GHz),
    ASUS P6T Deluxe V2, 12 GB RAM, Geforce 9800GT
    Windows 7 Ultimate,
    GV software: EDIUS 7.42, VisTitle v2.5,
    GV hardware: 3G Storm
    software SONY DoStudio Indie + EX 4.0.11
    PC 2
    Intel Core i7-3770, GIGABYTE Z77X-UD5H F14, 16GB RAM,
    Geforce 650 GTX, 5x HDD, Windows 7,
    GV software: EDIUS 7.42, ProCoder 3.0
    GV hardware: HD SPARK
    software: Telestream Switch, DTS-HD MAS, Dolby Media Meter

    Comment


    • #3
      Originally posted by Andreas_Gumm View Post
      At first, a clip processed by Virtualdub results always in a frame based progressive clip without any flag to recognize the right field dominance!
      From my experience I think that if EDIUS does not find a field order flag it will be always switched to TopFieldFirst for default!
      You always need to set the right field order manually in other NLE's!
      I think that it's high time that GV adds a checkbox in some settings which will tell Edius what kind of footage is it if it does not find the corresponding flag.

      I set field order manually, but it does not help. The result (exported footage from Edius) is the same whether you leave interlaced or change into progressive. I tried different combinations of progressive/interlaced project and/or clip properties as well.

      Originally posted by Andreas_Gumm View Post
      Do a test:
      Mount the already created & used AVISynth script by the AVFS (AVISynth file system) as an virtual uncompressed AVI & load this in EDIUS.
      Do a new comparison!
      When the clip is imported into Edius it shows that it is interlaced clip!

      Comment


      • #4
        Originally posted by crunchy View Post
        When the clip is imported into Edius it shows that it is interlaced clip!
        call me blind but I can't see any typical interlaced artifact.
        I see a slidely difference in your results but it could be caused by any reason.

        Did you mount the script with AVFS & did you load the virtual file in EDIUS?
        Andreas Gumm
        post production / authoring
        PC 1Intel Core i7-970 (6 x 3.20 GHz),
        ASUS P6T Deluxe V2, 12 GB RAM, Geforce 9800GT
        Windows 7 Ultimate,
        GV software: EDIUS 7.42, VisTitle v2.5,
        GV hardware: 3G Storm
        software SONY DoStudio Indie + EX 4.0.11
        PC 2
        Intel Core i7-3770, GIGABYTE Z77X-UD5H F14, 16GB RAM,
        Geforce 650 GTX, 5x HDD, Windows 7,
        GV software: EDIUS 7.42, ProCoder 3.0
        GV hardware: HD SPARK
        software: Telestream Switch, DTS-HD MAS, Dolby Media Meter

        Comment


        • #5
          Originally posted by Andreas_Gumm View Post
          call me blind but I can't see any typical interlaced artifact.
          Just compare lips on all the pictures. Of course it is not "interlaced" artefact due to the motion, but due to colour subsampling. I don't know how to call it.

          Originally posted by Andreas_Gumm View Post
          I see a slidely difference in your results but it could be caused by any reason.
          In my opinion they are not slight (you probably mean "slightly" and not "slidely"). Unfortunately, the whole video looks like it has somehow reduced resolution.

          Originally posted by Andreas_Gumm View Post
          Did you mount the script with AVFS & did you load the virtual file in EDIUS?
          Yes. I've done it one week ago and have done it again today. I "quick mounted" avs file. It took some time before bin window loads avi clip, but as I said, it is "top field first" and not progressive.

          I would really like to know what GV experts have to say about it.

          Comment


          • #6
            Originally posted by crunchy View Post
            ....but as I said, it is "top field first" and not progressive.

            I would really like to know what GV experts have to say about it.
            GV experts would say that any default value needs to be set!

            Top field first is the best decision if the field order has not been recognized.
            What does other NLEs do? Is the field order recognized correctly by e.g. Premiere?
            Or tells the other NLE just a different default setting?
            You always should control any clip for correct field order, especialy when it has been created by Vdub or feeded by AViSynth.
            If you correct the field order manually a interlaced issue couldn't be appear, so I assume your issue has other reasons.

            Do you have test clip for me? Just to have the same point of view!
            I need to test a little bit.

            Btw thank you for correcting me.
            Using "slidely" instead of "slightly" was totally wrong. I'm sorry for that.
            Andreas Gumm
            post production / authoring
            PC 1Intel Core i7-970 (6 x 3.20 GHz),
            ASUS P6T Deluxe V2, 12 GB RAM, Geforce 9800GT
            Windows 7 Ultimate,
            GV software: EDIUS 7.42, VisTitle v2.5,
            GV hardware: 3G Storm
            software SONY DoStudio Indie + EX 4.0.11
            PC 2
            Intel Core i7-3770, GIGABYTE Z77X-UD5H F14, 16GB RAM,
            Geforce 650 GTX, 5x HDD, Windows 7,
            GV software: EDIUS 7.42, ProCoder 3.0
            GV hardware: HD SPARK
            software: Telestream Switch, DTS-HD MAS, Dolby Media Meter

            Comment


            • #7
              Andreas,
              You do great. I couldn't respond to you in German :)
              Jerry
              Six Gill DV
              www.sgdvtutorials.com
              If you own the Tutorials and you need help, PM me.

              Vistitle YouTube Channel
              https://www.youtube.com/channel/UCMVlxC8Am4qFbkXJRoPAnMQ/videos

              Windows 10 Pro up to v.1803 Tweaks for Edius Users
              http://sgdvtutorials.com/WIN%2010%20...%20V.2.0.0.pdf


              Main System:: Azrock Z97 Extreme 6, [email protected], 32gb ram, NZXT Z63, Win10 Pro 64, Samsung 850 pro, E7.5/8.5/E9 on separate SSD drives, 2TB Sabrent M.2 NVME, BM MINI MONITOR 4K, 12tb RAID 0 on backplane ,2 BD, Dual LG 27GK65S-B 144Hz monitors, GTX 1080ti SC Black.
              Second System: EditHD Ultimax-i7, X58, [email protected], Corsair H80, Win764, 24gb ram, Storm 3g, Samsung 840 Pro 256, 4tb and 6tb RAID 0 on backplane, GTX 980ti Classified, Edius 9, Apple 30", Samsung 24", dual BD.

              Comment


              • #8
                Originally posted by Andreas_Gumm View Post
                GV experts would say that any default value needs to be set!
                I agree. So they should provide that user decides what kind of clip it is if the flag is not recognized. I don't think that it would be productive if GV answers that some other editors do not have such an option. If Edius can decide by itself what to do, why user can't help Edius in this task? Moreover, adding such a checkbox would cost them very little development time.

                Originally posted by Andreas_Gumm View Post
                If you correct the field order manually a interlaced issue couldn't be appear, so I assume your issue has other reasons.
                I am also wondering what could be the reason. As far as I can see, Edius interprets the footage in a wrong way even though it is manually marked as progressive. However, I might be wrong.

                Originally posted by Andreas_Gumm View Post
                Do you have test clip for me? Just to have the same point of view! I need to test a little bit.
                Clip is here:
                http://wtrns.fr/TMf1rnL8mmKeXo
                I cut it with freeware version of Smart Cutter, so there is a label "FAME" at the beginning and at the end of the clip. Other parts of the footage are not re-encoded.

                Please, use frame 100 for comparison.

                The first picture is the original cropped frame, enlarged 200%:

                The second is export of original MTS video via VirtualDub by using Lossless Canopus Codec. There is practically no difference between both.

                The third picture is original MTS video imported into Edius (1920x1080p25, 10-bit project), marked as progressive and exported by using lossless Canopus codec.

                The last one is the same as the previous one, but exporting by using Canopus HQ Fine codec.
                Attached Files
                Last edited by crunchy; 06-18-2011, 01:33 PM.

                Comment


                • #9
                  Do the chroma problem exist in an interlaced project as well?
                  You can try it with the clip properties set to Interlaced and Progressive as well.

                  I think in an 50i project with the clip set to interlaced, the chroma resolution won't be halved.
                  Dell T1650, 8GB ram, SSD, Win 7, Edius 6.08+HDSpark, Vistitle

                  Comment


                  • #10
                    Originally posted by HamonSerrano View Post
                    Do the chroma problem exist in an interlaced project as well?
                    As far as I remember, there were similar results, but I will test it again.

                    Comment


                    • #11
                      Hi Crunchy,

                      after a short view I can see not any difference!

                      1. step:
                      I have loaded your clip with AVISynth (with DGAVCIndex from Neuron, not DirectShowSource!), loaded it in VirtualDub & exported it to YUV2 HQ + Losless AVI.

                      2. step:
                      I have loaded the original cut.MTS clip in EDIUS project ([email protected]) & changed the field dominance to progressive! Now I exported it to HQ + Losless AVI.

                      3. step:
                      I compared the Losless & the HQ clips by loading all in different Vdub instances at the same time! I applied a crop to all & zoomed to 200%!
                      No visual difference!

                      4. step:
                      I created screenshots in all Vdub instances by "Copy output frame to clipboard (CTRL+2)" & paste it in a photoshop document in two different layers. I checked by toggling the top layer on & off!
                      No visual difference!

                      5. step:
                      So I doubled the resolution by doubling the pixel ("keep hard borders" or similar option, I use german PS) & exported the attached PNG's.

                      So take a look at the files to compare!

                      One thing: since your footage is YV12 (4:2:0) & EDIUS works internally YUV2 (4:2:2) a chroma conversion will happen! But without going to be badder.
                      The same has been applied by me in Vdub --> exporting to YUV2 color!

                      I think you have created screens with different methods in your test scenario, maybe direct from EDIUS to JPEG?
                      It seems that conversion of all assets to the same type of color is missed!

                      cheers
                      Attached Files
                      Last edited by Andreas_Gumm; 06-18-2011, 09:30 PM.
                      Andreas Gumm
                      post production / authoring
                      PC 1Intel Core i7-970 (6 x 3.20 GHz),
                      ASUS P6T Deluxe V2, 12 GB RAM, Geforce 9800GT
                      Windows 7 Ultimate,
                      GV software: EDIUS 7.42, VisTitle v2.5,
                      GV hardware: 3G Storm
                      software SONY DoStudio Indie + EX 4.0.11
                      PC 2
                      Intel Core i7-3770, GIGABYTE Z77X-UD5H F14, 16GB RAM,
                      Geforce 650 GTX, 5x HDD, Windows 7,
                      GV software: EDIUS 7.42, ProCoder 3.0
                      GV hardware: HD SPARK
                      software: Telestream Switch, DTS-HD MAS, Dolby Media Meter

                      Comment


                      • #12
                        Thank you very much! The results are really very interesting! I'll have to repeat your procedure. Is there any reason why you are using DGAVCIndex instead of DirectShowSource?

                        Originally posted by Andreas_Gumm View Post
                        4. step:
                        I created screenshots in all Vdub instances by "Copy output frame to clipboard (CTRL+2)" & paste it in a photoshop document in two different layers. I checked by toggling the top layer on & off!
                        No visual difference!
                        I would like to clarify your step 4. As far as I remember, VirtualDub, by default, shows output frame BEFORE conversion.
                        Can you do the following: Open already converted clips and "Copy input frame to clipboard (CTRL+1)" - just to be sure that we really compare the results?

                        Comment


                        • #13
                          Originally posted by crunchy View Post
                          Is there any reason why you are using DGAVCIndex instead of DirectShowSource?
                          DGAVCIndex is much more reliable with speed access, color matching & decoding. DirectShowSource just depends on the installed filter package! Scrubbing with the file stutters!

                          Originally posted by crunchy View Post
                          I would like to clarify your step 4. As far as I remember, VirtualDub, by default, shows output frame BEFORE conversion.
                          Can you do the folling: Open already converted clips and "Copy input frame to clipboard (CTRL+1)" - just to be sure that we really compare the results?
                          Don't worry, at this point all conversions has been already applied! ;)
                          I just reloaded the already converted AVI files in Vdub & did the screen shot!

                          cheers
                          Andreas Gumm
                          post production / authoring
                          PC 1Intel Core i7-970 (6 x 3.20 GHz),
                          ASUS P6T Deluxe V2, 12 GB RAM, Geforce 9800GT
                          Windows 7 Ultimate,
                          GV software: EDIUS 7.42, VisTitle v2.5,
                          GV hardware: 3G Storm
                          software SONY DoStudio Indie + EX 4.0.11
                          PC 2
                          Intel Core i7-3770, GIGABYTE Z77X-UD5H F14, 16GB RAM,
                          Geforce 650 GTX, 5x HDD, Windows 7,
                          GV software: EDIUS 7.42, ProCoder 3.0
                          GV hardware: HD SPARK
                          software: Telestream Switch, DTS-HD MAS, Dolby Media Meter

                          Comment


                          • #14
                            Originally posted by Andreas_Gumm View Post
                            So take a look at the files to compare!
                            ...
                            I think you have created screens with different methods in your test scenario, maybe direct from EDIUS to JPEG?
                            It seems that conversion of all assets to the same type of color is missed!
                            I have tried with DGAVCIndex by using the following avs script:

                            loadplugin("DGAVCDecode.dll")
                            AVCSource("Cut.dga")

                            Then the script is imported into VirtualDub. Only setting I used in VD is "Video Compression" where I selected the codec. First Canopus LossLess, then Canopus HQ Fine.

                            After making both avi files, I opened them inside VirtualDub, find frame 100 and copied it to the clipboard. In picture editor I pasted the picture, cropped it and resized it by 200% (by using nearest-neighbour method).

                            The results are shown below (First picture is lossless, the second is HQ).

                            My results are somehow better than yours when using Canopus lossless codec and clearly show the difference between both codecs. I cannot understand why.

                            Have you checked your settings in VirtualDub preview?
                            Attached Files

                            Comment


                            • #15
                              Originally posted by crunchy View Post
                              I have tried with DGAVCIndex by using the following avs script:

                              loadplugin("DGAVCDecode.dll")
                              AVCSource("Cut.dga")

                              Then the script is imported into VirtualDub. Only setting I used in VD is "Video Compression" where I selected the codec. First Canopus LossLess, then Canopus HQ Fine.

                              After making both avi files, I opened them inside VirtualDub, find frame 100 and copied it to the clipboard. In picture editor I pasted the picture, cropped it and resized it by 200% (by using nearest-neighbour method).

                              The results are shown below (First picture is lossless, the second is HQ).

                              My results are somehow better than yours when using Canopus lossless codec and clearly show the difference between both codecs. I cannot understand why.

                              Have you checked your settings in VirtualDub preview?
                              The difference between my & your result is the different resizing quality method!
                              You have used "nearest neighbour method"! It interpolate more pixels.
                              I used a different one! Doubling pixel (does't know the english phrase) archives the picture characteristic.
                              Next thing is what did you set in HQ codec details? I used "fine" all the time!

                              Did you export the clip to YUV2?
                              Just to know if we are in the same scenario.
                              Andreas Gumm
                              post production / authoring
                              PC 1Intel Core i7-970 (6 x 3.20 GHz),
                              ASUS P6T Deluxe V2, 12 GB RAM, Geforce 9800GT
                              Windows 7 Ultimate,
                              GV software: EDIUS 7.42, VisTitle v2.5,
                              GV hardware: 3G Storm
                              software SONY DoStudio Indie + EX 4.0.11
                              PC 2
                              Intel Core i7-3770, GIGABYTE Z77X-UD5H F14, 16GB RAM,
                              Geforce 650 GTX, 5x HDD, Windows 7,
                              GV software: EDIUS 7.42, ProCoder 3.0
                              GV hardware: HD SPARK
                              software: Telestream Switch, DTS-HD MAS, Dolby Media Meter

                              Comment

                              Working...
                              X