Announcement

Collapse
No announcement yet.

Low Level Fizzing Audio Artifacts in DVD Encoding

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • tingsern
    replied
    Hi David / Brandon,

    I always stick to WAV for my DVD productions. Especially when I record in concert halls (classical recordings). The sounds are so much better than any encoded sounds (MPEG Layer 2, Layer 3, or even AC-3). Really telling in the depth of the recorded sound.

    I use a 24 bits 96Khz digital sound recorder for the original sound recording, which I then merge into the video (after downsampling to 16 bits, 48Khz).

    With a DVD - no problem with space.

    TS
    Last edited by tingsern; 07-22-2007, 05:41 AM.

    Leave a comment:


  • GrassValley_BH
    replied
    You're welcome David.

    MPEG-1 Layer II audio compression is... well... just okay.
    It was the thing when it first came out back in the early 90's though. I remember running DOS compressors on them.

    MPEG-1 Layer III, on the other hand, is much better.

    Still, for DVD use, my preference would be AC-3. EDIUS v4.5 will include AC-3 encoding, both in the new DVD authoring as well as timeline export, so once the upgrade comes out you can move toward using AC-3 instead.

    Leave a comment:


  • djspearritt
    replied
    Brandon

    Originally posted by GrassValley_BH View Post
    MPEG audio for DVDs is MPEG Layer II encoding, not Layer III (aka MP3).
    Yes, sorry for confusing that issue.

    Can you compress to MPEG Layer II in Wavelab? Also, please provide the audio encoding settings.
    Yes I can, and when the settings are 48kHz and 192 kbps, the artifacts are there in Wavelab encoded file as well. So its the same error in the encoder for Wavelab as in ProCoderExpress.

    The story seems to be to keep well away from MPEG2 audio output for the DVD. Its going to be only 48/16 PCM WAV for me.

    Thanks for your help Brandon.

    Regards
    David Spearritt
    http://www.lodestarrecordings.com.au

    Leave a comment:


  • GrassValley_BH
    replied
    Originally posted by djspearritt View Post
    If I take the same WAV file and convert it to MP3 in Wavelab, there are no artifacts generated.
    MPEG audio for DVDs is MPEG Layer II encoding, not Layer III (aka MP3).

    Can you compress to MPEG Layer II in Wavelab?

    Also, please provide the audio encoding settings.

    Leave a comment:


  • tingsern
    replied
    Hi David,

    May I point out to you that I am just a user (like you). You probably thought I was a Canopus developer / tech support - for which I am certainly not. I was trying to help you figure out the source of the problem.

    Please refer to the previous note (which I requested the original noise WAV - without amplification) and the settings you provide ProCoder Express with. I can try to recreate the problem and see if I can tell what is wrong?

    On a side note, have you applied ALL the fixes to EDIUS and Procoder Express that are applicable (download them from Canopus website)?

    Cheers,
    TS

    Leave a comment:


  • djspearritt
    replied
    I am not interested in spectral analysis, or in how many dB the level is down. The fact is that there are artifacts which are clearly audible (ie. with one's ears, not a spectrum analyser!) and objectionable and they are associated with the MPEG2 audio decoding of ProCoderExpress.

    I hope you pursue this and sort it out. Artifacts, by their very nature will always be at a low level, but this certainly doesn't mean that they should be ignored. It points to significant errors and corruption in the encoder. One cannot take this encoder seriously until these artifacts are removed.

    Regards
    David Spearritt
    http://www.lodestarrecordings.com.au

    Leave a comment:


  • tingsern
    replied
    Okay - what I did was to use EDIUS to open the "original.wav" file, drag the audio file into timeline, and then export the timeline to file, using ProCoder Express. I specified "DVD", and "MPEG1 Layer 2" - so, it gave me one video file (which I deleted), and one audio (m2a). Did a spectrum analysis of the m2a file (same parameters as original and MP3 *encoded by ProCoder 3*) - the output of which you can see below. It is just a bit noisier (by 2 or 3dB) - but, you have to bear in mind this noise is at -70dB ... which is basically below the floor noise of most audio amplifiers.

    In short, I still can't reproduce your noise problem.
    Attached Files

    Leave a comment:


  • tingsern
    replied
    Can you post me the following items - (a) the non-amplified MP3 sound (output directly from ProCoder Express), (b) the parameters you passed to ProCoder Express to generate that MP3 from the original WAV file? I will do some experiments and see if I can tell where that "extras" come from?

    Generally, to "compress" sounds - the MP3 or AAC algorithm looks for "symbols" to substitute - if it can't find any (like in your case), it might magnify random noises (aircons, microphone noises, etc).

    Fact is your original all contain sounds at -80dB from 1hz all the way to 500hz. Did you turn on the mic's low frequency filter to cut off 30hz and below? I haven't seen a microphone good enough to capture 30hz without distortion. 50hz - fine.

    *** More info ***
    I went into ProCoder Express for EDIUS to try to convert your original WAV file to MP3. Under "Load Source", I can't even find WAV as an acceptable input medium for this program !!! I wonder how you managed to convert your WAV to MP3 then? For that matter, I think ProCoder Express is only accepting VIDEO files as valid input, not pure AUDIO files.
    Last edited by tingsern; 07-15-2007, 03:07 PM.

    Leave a comment:


  • djspearritt
    replied
    Many thanks for your efforts, but I am using ProCoderExpress inside Edius 4 Pro. It seems the problem is with ProCoderExpress, not ProCoder3. These artifacts are clearly audible when playing the DVD, just before the music starts.

    If I take the same WAV file and convert it to MP3 in Wavelab, there are no artifacts generated.

    Leave a comment:


  • tingsern
    replied
    Hi,

    I downloaded your original WAV, and passed it thru ProCoder 3. Output as 192KHz MP3 file. I then did a spectrum analysis on both WAV and MP3 using 16384 samples FFT and Blackman-Harris algorithm. The outputs can be been as attachments. I would say that there is NO audible difference between the original and the MP3 file.

    In both cases, you are listening to "sounds" at -80dB on average. Looking at the FFT, the MP3 is quieter than the original.

    TS
    Attached Files

    Leave a comment:


  • djspearritt
    replied
    But I posted the gained up encoding artifacts in the first file in this thread. The artifacts are clearly audible. For a classical music video application, these artifacts are a serious problem with this encoder.

    I hope Canopus will take this issue seriously.

    Leave a comment:


  • SRsupport
    replied
    That wav level is way to low to hear I the artifacts are present in it. You have to apply a great amount of gain before you can imagine to hear something.
    Can't do a test with this sorry.

    SR

    Leave a comment:


  • djspearritt
    replied
    Bump bump.

    Leave a comment:


  • djspearritt
    replied
    Here is the original 48/16 WAV.
    http://www.lodestarrecordings.com.au...s/original.wav

    Leave a comment:


  • SRsupport
    replied
    Give the original file and I can encode to listen to the results and compare it to yours. The file that you put up has an extra encoding step.
    Last edited by SRsupport; 07-09-2007, 12:54 PM.

    Leave a comment:

Working...
X