Announcement

Collapse
No announcement yet.

Firewire bus reset???

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Firewire bus reset???

    I'm using ULead software to capture VHS -> ADVC-300 -> FireWire -> AVI. This probably isn't an ADVC-300 problem, but I'm not sure about that; figured I'd ask here anyway.

    When the capture is in progress, , I frequently get the error message below in the XP event log. It seems that the Firewire bus is resetting itself, which stops the video capture.

    When this happens, the Imaging Device in the XP Device Manager disappears. In a few seconds, the device reappears and I can restart the capture.

    I have a SIIG FireWire 800 PCI-32T card, using the Microsoft Firewire 400 drivers. The Capture Service in the event log is operated by this InterVideo file:

    C:\Program Files\Common Files\InterVideo\DeviceService\DevSvc.exe

    Having capture sessions interrupted 10-15 times a day is a MAJOR pain in the neck. Any suggestions?

    Event Type: Information
    Event Source: Capture Device Service
    Event Category: None
    Event ID: 0
    Date: 7/20/2007
    Time: 6:57:51 PM
    User: N/A
    Computer: ***
    Description:
    The description for Event ID ( 0 ) in Source ( Capture Device Service ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: [CDeviceServiceModule::RemoveFromMap]:
    Removed device name Microsoft DV Camera and VCR

  • #2
    I've seen this happen with FireWire drives. It can happen if there are a number of devices daisy-chained, if there's a "bus storm" or if you have bad cabling.

    Comment


    • #3
      Thanks for the response. Microsoft has a couple support docs regarding Firewire, but neither of them helped resolve the problem (although they do make interesting reading).

      http://support.microsoft.com/kb/314873

      http://support.microsoft.com/kb/885222

      I'll try a different firewire cable and see if that helps. What a pain!

      Comment


      • #4
        You definitely want to disable the 1394 Network adapter if one got installed (which it probably did).

        Comment


        • #5
          Well, I installed a new Firewire cable. No change. Still getting the error. I also disabled the 1394 network adapter (in Device Manager). That made things WORSE. ULead Video Studio won't recognize the capture device unless the network adapter is ENabled.

          I've been searching around the Microsoft support site for anything related to IEEE 1394 and the XP drivers that run the ADVC300. Here are a couple screen shots of the driver details.





          I'm not sure what to expect, if anything. Maybe I should just give up and live with the problem...

          Comment


          • #6
            Have you tried capturing from another device such as a DV video camera? That would tell you if the problem is with the ADVC-300 or somewhere else.

            Also, you could try another capturing program such as the free WinDV just in case Ulead is doing something strange on your computer. WinDV also allows you to turn off device control (untick the little box between the Config and Capture buttons) in case that is causing problems.

            Lastly, are you capturing to an external HDD? If so, try capturing to an internal HDD. If you are capturing to an internal HDD, make sure it has a sufficiently high transfer rate. You can use the free Roadkil's Disk Speed to test your transfer rate.

            Ken.
            Last edited by kbosward; 08-02-2007, 01:41 PM.

            Comment


            • #7
              Something is very wrong... At this point I'd just go and buy a $10 FireWire 400 card from the store and see if it'll work properly on that.

              Comment


              • #8
                Came across this interesting article which talks about bus resets with Firewire 800 cards:
                http://www.rme-audio.com/english/tec...fw800alert.htm

                I agree with Brandon, go and buy a Firewire 400 card.

                Ken.

                Comment


                • #9
                  Many thanks for the input! I'll get a FW 400 card and see what happens. I have a feeling the RME article is right on the money...

                  FYI, I'm capturing files to an internal Maxtor 250 GB SATA drive. I haven't tested its transfer rate, but the problem occurs even when I'm NOT capturing video.

                  Software I've tried includes WinDV, Windows MovieMaker, ULead Video Studio 8 and DVD Factory 6.
                  Last edited by saunan; 08-08-2007, 06:56 AM. Reason: Added additional facts

                  Comment


                  • #10
                    Problem solved

                    A new, cheap Firewire 400 card solved the problem. Encore Electronics, ENL1394-PCI. It has the VIA chipset, and works fine... Thanks to everyone who posted on this topic!

                    Comment


                    • #11
                      As un-ideal as it is to say, often times it's faster to simply go around a problem than to try solving it.

                      Comment


                      • #12
                        Originally posted by saunan View Post
                        ENL1394-PCI. It has the VIA chipset, and works fine...
                        Just for info : IEEE1394 cards with VIA or NEC chipsets are common cause for audio drop outs, if possible stick to Texas Instruments.

                        Comment

                        Working...
                        X